The updated SDK could not be installed

windows

#1

When i update my sdk from version 3.4 to 4.0.The menu shows me that ‘setup was not completed successfully’.I dont find the way to solve,could some give me any ideas about how to deal with this problem?%E6%9C%AA%E5%91%BD%E5%90%8D1520142698


#2

When you click “Show details”, what does it say?


#3

Just ran into the same issue. I don’t know if @617475jordan has the exact same error, however for me details show the following:

installing VC++ runtime 2015 return -1
Encountered an error while trying to install VC++ runtime 2015


#4

OK, this usually means that you have a newer version of the VC '15 runtime installed than the one that is packaged with the installer (see https://msdn.microsoft.com/en-us/library/ms235299.aspx for the gory details).

TBH, this is a bug we need to fix in our install logic, but a workaround for now would be to temporarily uninstall the latest MSVC 2015 redistributable (via Control Panel), then install the Affectiva SDK, and then reinstall the latest redistributable afterward. Sorry for the hassle :frowning:


#5

thanks for the quick reply.

You’re absolutely right. the install seems to work fine following your suggested workaround.

thanks again for the help


#6

yeah,i have solved this problem,we should uninstall other vc runtimes.It’s so bad


#7

Dear andy_dennie

     I am glad that i receive your suggestion.Now the problem has been solved ,we should uninstall all vc runtimes including(2008,2010,2013,even 2017).

From Ni

On 3/5/2018 04:54,Almar van der Stappenaffectiva@discoursemail.com wrote:


#8

Now the problem has been solved ,we should uninstall all vc runtimes including(2008,2010,2013,even 2017)


#9