Dagger Version in Android SDK and Two Daggers Conflict

I was wondering if Affectiva SDK 3.2 is depending on which dagger version ?, and if SDK 4.0 is coming to Android soon ?

As I have a current project that is conflicting with it, and the two daggers blog is just not relevant anymore, and too complicated to maintain.