Cannot build opencv-webcam-demo


#1

Hey there… I’m running in a problem with building c++ sdk samples. When running cmake, I get this:

[ 50%] Linking CXX executable opencv-webcam-demo                                                                                            
/usr/bin/ld: cannot find -lQt5::Core                                                                                                        
/usr/bin/ld: cannot find -lQt5::Gui                                                                                                         
/usr/bin/ld: cannot find -lQt5::Widgets                                                                                                     
/usr/bin/ld: cannot find -lQt5::Test                                                                                                        
/usr/bin/ld: cannot find -lQt5::Concurrent                                                                                                  
/usr/bin/ld: cannot find -lQt5::OpenGL 

When I run it on a clean install (such as in a VM), it builds fine, but I need to run it on a machine that hosts other applications as well. I’ve run the build successfully on this very machine and this very OS install earlier today, but after installing other dependencies for my project (zeromq, messagepack) and pupil (http://pupil-labs.com), I can build the example no more. Any ideas?


#3

I think you have withdrawn this post so I will close this issue for now, feel free to open another one if the problem arises.


#4